Skip to main content
All CollectionsEmail Quarantine AutomationFAQs
Issue: Google Admin Is Unable To Authorize RH Applications
Issue: Google Admin Is Unable To Authorize RH Applications
K
Written by Karthek S
Updated over a week ago

Table of contents.

Issue

While authorizing the RH application, the error below occurs.

Potential Cause

The error message "400 admin_policy_enforced" means that the G Suite administrator's configuration restricts access to third-party apps to Google Workspace data.

Step-by-Step Solution

  1. Login to your GSuite Admin portal.

  2. Navigate to Security > Access and data control > API controls. On the API controls page, click on Manage Third-party App Access.


    ​

  3. Click on Add App and then select OAuth App Name Or Client ID.

  4. Type or copy and paste the following Client ID in the search bar and click Search

    1. Client ID: 106061374448296891770

    2. Select the Right Hand GSuite Integration App

  5. Check the tick box of OAuth Client ID to select all the permissions.


    ​

  6. In the Scope section, highlight your Domain. Do not select an organizational unit (OU).

  7. Mark the Access as Trusted.

  8. Click Continue and Submit it.


​


​

Did this answer your question?